Resolved
This incident has been resolved.
Investigating
The request timeout issue has recurred after the initial mitigation.
Engineering is continuing investigation and working on additional mitigation. Further updates will be provided as we identify the cause or apply a new fix.
Monitoring
We have mitigated the request timeout issue by increasing server instance capacity. Request timeouts appear to have stopped after the scale-up.
The root cause has not yet been identified. Engineering will continue investigating the underlying cause and monitor system stability.
Investigating
Elevated Server Latency Causing Request Timeouts
We are investigating this issue.